Ваши комментарии

Добрый день.

Нужно изменить конфигурацию УТ

В модуле объекта Обработки ТОСервер в Процедуре ОбработатьТаблицуШтрихкодов нужно вставить 3 строчки (выделено жирным шрифтом):

Если Не РезультатЗапроса.Пустой() Тогда
РезультатЗапроса = РезультатЗапроса.Выбрать();
РезультатЗапроса.Следующий();

Номенклатура = РезультатЗапроса.Номенклатура;
ХарактеристикаНоменклатуры = РезультатЗапроса.ХарактеристикаНоменклатуры;
СерияНоменклатуры = РезультатЗапроса.СерияНоменклатуры;
Качество = РезультатЗапроса.Качество;
ЕдиницаИзмерения = РезультатЗапроса.ЕдиницаИзмерения;
Количество = Количество * РезультатЗапроса.Количество;

//RS
Если Не ЗначениеЗаполнено(Количество) Тогда
Количество = СтрокаТЧ.Количество;
КонецЕсли;
//~RS

НоменклатураНайдена = Истина;
КонецЕсли;
КонецЕсли;

значит, если не выгружать базу товаров, установить автопривязку ШК в настройках мобильной торговли, отсканировать не устанавливая префикс и загрузить на ПК - загрузится корректно

К сожалению качество не очень, распечатали и не удается отсканировать

Дело не в обработке и не в мобильной торговле, а в конфигурации УТ 10.3, обработка штрихкодов происходит в конфигурации, если только в ней изменения вносить

Как я понял, у этих ШК одинаковые GTIN и серии. Сейчас программа обрабатывает их не корректно. Не могли бы вы прислать фото двух этих ШК в хорошем качастве, попробуем что-нибудь сделать.

Попробуйте снять галочку весового штрихкода, в качестве штрихкода заполнить первые 7 знаков весового штрихкода (например "2300045"), выгрузить базу товаров на ТСД, установить в настройках сканирования в мобильной торговле префикс весового штрихкода ("23"), отсканировать ШК весового товара в документ 1С на тсд, загрузить данные в документ на ПК

А как заведен этот товар в УТ 10.3 - как весовой или нет? И какой у него штрихкод?



Сервис поддержки клиентов работает на платформе UserEcho