Ваши комментарии

Ну, видимо, поведение связки ТСД+ПО зависит либо от модели ТСД, либо от конкретного экземпляра ТСД, либо версии ПО, либо от от того, как звёзды расположились. У меня на UROVO шторка упорно не выдвигалась на нескольких аппаратах, потом на одном из них вдруг соизволила выдвинуться без перезагрузки.

>достаточно лишь выйти в "меню" лаунчера, где находятся настройки и список приложений

Приложение работает корректно, и если вам необходимо часто выбирать между стандартным лаунчером и RS, то используйте приложение правильно.

Открываем "Руководства пользователя RS:Launcher2", выполняем пункты 10-12. После смены лончера по этому алгоритму шторка не работает. Объясните мне, что именно я, якобы, делаю неправильно? А создатель приложения сам не пробовал проверить, как оно работает? Я непременно должен потратить своё время на запись видео с экрана?

Раз вы не знаете ответа на простейший вопрос, подскажу его вам я. Чтобы шторка заработала, после восстановления системного лончера нужно перезагрузить терминал. А то опять предложите отправить терминал в сервисный центр.

При отсутствии ТСД открываем https://ean-13.ru/online-generator-shtrihkodov.php , выбираем GS1 DataBar Expanded Stacked, вставляем текст ШК, генерим его 4х1, фотографируем телефоном.

Пример наших штрихкодов DataBar Expanded Stacked:

Весовой: (01)02705362000009(3103)000326(11)281020(17)260421(10)1810(21)2021

Штучный: (01)04603736340127(11)301020(17)280421(10)1810(21)2021



Обработка вызывает процедуру глобального модуля, цитирую её текст. Форматирование текста здесь как исходного кода, работает только в момент написания сообщения и теряется после его публикации.


Процедура глДобавитьСтроку(КЧему,Что,Счетчик=0,ОграничиватьКоличествоСтрок=0) Экспорт

//Чтобы размер окна не вышел за размеры экрана, когда текст предупреждения слишком большой, можно четвёртым параметром,

//не равным нулю, заставить процедуру вернуть текст с количеством строк, ограниченным некоторым значением.

//От получившегося после прибавления к КЧему очередной порции текста Что оставляем в этом случае первые 18 строк и последнюю,

//между ними будет расположена строка с многоточием, означающая вырезанные строки.

Перем х,ВспомСтр,ВсегоСтрок;

КЧему=КЧему+?(ПустаяСтрока(КЧему)=1,"",РазделительСтрок)+Что;

Если ОграничиватьКоличествоСтрок<>0 Тогда

ВсегоСтрок=СтрКоличествоСтрок(КЧему);

Если ВсегоСтрок>20 Тогда

ВспомСтр=КЧему;

КЧему="";

Для х=1 По 18 Цикл

КЧему=КЧему+?(х=1,"",РазделительСтрок)+СтрПолучитьСтроку(ВспомСтр,х);

КонецЦикла;

КЧему=КЧему+РазделительСтрок+"....."+РазделительСтрок+СтрПолучитьСтроку(ВспомСтр,ВсегоСтрок);

КонецЕсли;

КонецЕсли;

Счетчик=Счетчик+1;

КонецПроцедуры

Доработанная мной обработка для 1С 7.7 Торговля Выгрузить штрихкоды в ТСД UROVO.ert - может кому пригодится. А то ваша совсем уж наспех была сделана и выгружала втрое больше записей, чем нужно.

Большое спасибо, теперь работает как надо.

Особенности:

1) Обновлять старую версию приложения нельзя - невозможно запустить новую из-за бесконечно повторяющейся ошибки. Удаление всех данных в старой версии (из самого приложения) не помогает, нужно полностью удалять старую версию перед установкой новой.

2) После загрузки номенклатуры сканирование товара в документы не работает, пока не перезагрузишь ТСД.



Сервис поддержки клиентов работает на платформе UserEcho