0
Исправлен

UROVO i6200A. Мобильный клиент.

Есть UROVO i6200A, пытаюсь на нем запустить сканер из мобильного КЛИЕНТА 8.3.17.67, НЕ мобильного приложения.
Работают ли драйвера из 1С БПО для мобильного приложения или ваш драйвер RSDriver 1.20 именно в мобильном клиенте?(1.21 пока не пробовал, сегодня собираюсь)

Эти два драйвера устанавливаются и подключаются без ошибок , но на кнопку SCAN никакой реакции.
Как устанавливаю драйвера и подключаю устройство:

Функция ИнициализироватьДрайверБПО() Экспорт
//#Если МобильныйКлиент Тогда
Оповещение = Новый ОписаниеОповещения("ПодключитьВК_Из_БПО", ЭтотОбъект);
НачатьУстановкуВнешнейКомпоненты(Оповещение, "ОбщийМакет.ДрайверRightScanУстройстваВвода");
//#КонецЕсли
Возврат Ложь;
КонецФункции
Процедура ПодключитьВК_Из_БПО(Дополнительные_Сообщения)Экспорт 
Оповещение = Новый ОписаниеОповещения("НастройкаВК_Из_БПО", ЭтотОбъект);
НачатьПодключениеВнешнейКомпоненты(Оповещение, "ОбщийМакет.ДрайверRightScanУстройстваВвода","RSDriver", ТипВнешнейКомпоненты.Native);
КонецПроцедуры
Процедура НастройкаВК_Из_БПО(Подключено, Дополнительные_Сообщения)Экспорт 
Если Подключено Тогда
Попытка
глВКRSDriver = Новый ("AddIn.RSDriver.RSDriver");//Создает объект драйвера
ПодключитьУстройство();
Исключение
_Сообщение = ОписаниеОшибки();
Сообщить(_Сообщение);
МобильныйМодульСервер.Записать_СообщениеВРегистрЛог(_Сообщение);
_Сообщение = "Ошибка создания класса БПО";
Сообщить(_Сообщение);
МобильныйМодульСервер.Записать_СообщениеВРегистрЛог(_Сообщение);
Подключено = Ложь;
Конецпопытки;
Иначе
_Сообщение = "Компонента БПО не загружена";
Сообщить(_Сообщение);
МобильныйМодульСервер.Записать_СообщениеВРегистрЛог(_Сообщение);
КонецЕсли;
КонецПроцедуры

Подключает само устройство

Процедура ПодключитьУстройство()
Попытка
глВКRSDriver.УстановитьПараметр("Barcode_BEEP",Истина);
глВКRSDriver.УстановитьПараметр("Barcode_BZZ",Истина);
Ответ = глВКRSDriver.Подключить("Barcode");             Если Ответ Тогда
_Сообщение = НСтр("ru='Устройство подключено ! ! !'") + Символы.ПС + ОписаниеОшибки();
Сообщить(_Сообщение);
МобильныйМодульСервер.Записать_СообщениеВРегистрЛог(_Сообщение);
Иначе
_Сообщение = НСтр("ru='Ошибка подключения!'") + Символы.ПС + ОписаниеОшибки();
Сообщить(_Сообщение);
МобильныйМодульСервер.Записать_СообщениеВРегистрЛог(_Сообщение);
КонецЕсли;
Исключение
_Сообщение = НСтр("ru='Ошибка вызова метода <ОбъектДрайвера.Подключить>.'") + Символы.ПС + ОписаниеОшибки();
Сообщить(_Сообщение);
МобильныйМодульСервер.Записать_СообщениеВРегистрЛог(_Сообщение);
КонецПопытки;
КонецПроцедуры

Ответ = глВКRSDriver.Подключить("Barcode"); - ошибки не выдает, но и сканер не реагирует.
Правильно ли я подключаю через ("Barcode", может надо "Keyboard" или надо еще какие то параметры установить ?
На этом ТСД еще установлена 1С Мобильная торговля, там сканер естественно работает.

ПЛОХО, МНЕ НЕ ПОНРАВИЛОСЬ
Оценка удовлетворенности от Алексей В. 1 месяц назад
На рассмотрении

Проверяете на каком веб сервере? 

Добрый день.

Попробуйте компоненту OIDD.

Функция ИнициализироватьВнешнююКомпонентуOmniInputDeviceDriver () Экспорт

#Если МобильноеПриложениеКлиент ИЛИ МобильныйКлиент Тогда

Если ПодключитьВнешнююКомпоненту("ОбщийМакет.OIDD", "OmniIDD", ТипВнешнейКомпоненты.Native) Тогда

Попытка

глВК_OmniIDD = Новый ("AddIn.OmniIDD.OmniIDD");

глВК_OmniIDD.Подключить("Barcode");

глВК_OmniIDD.Подключить("Keyboard");

Возврат Истина;

Исключение

Конецпопытки;

Иначе

КонецЕсли;

#КонецЕсли

Возврат Ложь;

КонецФункции

Компонента устанавливается, Barcode и Keyboard подключаются без ошибок , но при нажатии Scan мобильный клиент вылетает.

Точнее один раз вылетело. Сейчас не вылетает, но сканер не реагирует.
Попробовал
глВК_OmniIDD.Подключить("Barcode");

глВК_OmniIDD.Подключить("Keyboard");
для других драйверов, для RSDriver 1.21 и из БПО ДрайверRightScanУстройстваВвода, результат такой же, все подключается без ошибок, но сканер не реагирует, то есть в ОбработкаОповещения ничего не приходит.

Мы планируем использовать сканер в мобильном клиенте с автономным режимом.
Попробовал на 8.3.13.64, из БПО ДрайверRightScanУстройстваВвода при сканировании мобильный клиент вылетает, RSDriver 1.21 и OmniIDD все также устанавливается/подключается без ошибок, но в ОбработкаОповещения ничего не приходит.

А вообще работает у кого то на этой модели ТСД на мобильном клиенте с автономным режимом?

На этом ТСД есть 1С Мобильная торговля и в ней сканер работает, какой драйвер используется в 1С Мобильная торговля и кусок кода подключения драйвера используемый в  1С Мобильная торговля можете написать?

Также для apache в httpd.conf нужно прописать 

AddType application/octet-stream .so

в мобильной торговле OIDD используется, кусок кода именно с мобильной торговли взят

Сервис поддержки клиентов работает на платформе UserEcho