0
Завершен

RSDriverAPI настройки распознавания голоса и прослушивания текста для 1С.

1. Как бы получить полное описание программного интерфейса по этой компоненте (собственно это касается и RSExchange)

2. При использовании RSDriver не удалось задействовать голосовые функции (как распознавание, так и синтезатор).По крайней мере на i6200 и v5100. Отсюда вопрос: КАК???

Ответ

Ответ
Завершен

Вот как необходимо установить и настроить Google TTC для воспроизведения голоса через RS Driver API

не забываем перегрузить ТСД.


На рассмотрении

1. Все по RS Driver тут  http://solutions.rightscan.ru/rs-api/  внизу описание и примеры конфигурации с открытым кодом

2. для использования голоса необходимо установить на устройство библиотеки GOOGLE для распознавания и TCC для воспроизведения


после установки необходимо перезагрузить устройство, чтобы инициализировались новые библиотеки в RS-CORE


про TTC чуть позже скину

Ответ
Завершен

Вот как необходимо установить и настроить Google TTC для воспроизведения голоса через RS Driver API

не забываем перегрузить ТСД.


после данных действий все работает в OFF Line  Режиме

Доброго дня! Само распознавание на устройстве работает, но ощущение, что данные до приложения не доходят

я выполнил все как на скриншотах. у меня все заработало. не забывайте перегрузить устройство.

Смс голосом я набрать могу, но в событии "Voice" параметр приходит пустым

Разумеется, устройство было перегружено

Я имею ввиду не сам сервис распознавания, его функции при работе драйвера RSDriver

я про него и говорю.
у вас стоит на Устройстве стоит RS-CORE?
также убедитесь что у вас свежая версия RS-Driver-Api  http://solutions.rightscan.ru/rs-api

И я про него, разумеется установлено, и версия последняя, что по ссылке, сейчас еще раз перепроверил, изменений нет. Все работает, все методы и события перепроверил сам, за исключением события Voice, в нем параметр в мобильном приложении всегда возвращается пустым. Активацию я переставил на физическую кнопку "Talk" для удобства. Собственно аналогичный результат имеем и с вашим демо-приложением, все работает кроме распознавания.

Что то вы не так значит делаете.
я взял ТСД чистый из коробки
установил все как показано на рисунках сверху

перезагрузил его

запустил RS driver API

все работало

https://goo.gl/photos/gzkUEU4hkDdc1orT7


Если в Москве привозите ТСД посмотрим что не так настроено. но однозначный что то не так делаете. 

Ок. привезем. Дмитрий, что там можно не так делать? Если б что то было не так, то я бы не смог смс голосом набрать на этом аппарате offline. В приложении активация Voice происходит (характерный звук колокольчика) (в вашем demo-приложении при Слушать -> Начать), а после произнесения слова, параметр возвращает пустое значение.

Вы можете воспользоваться типовым механизмом от 1С. будет работать off-line
это будет выглядеть следующим образом

&НаКлиенте
Функция ПолучитьТекстГолосовойКоманды(Заголовок="Говорите")

#Если МобильноеПриложениеКлиент Тогда
Текст = "";
НовоеВзаимодействие = Новый ЗапускПриложенияМобильногоУстройства("android.speech.action.RECOGNIZE_SPEECH");
НовоеВзаимодействие.Действие = "android.speech.action.RECOGNIZE_SPEECH";
НовоеВзаимодействие.ДополнительныеДанные.Добавить("android.speech.extra.PROMPT",Заголовок,"String");
Результат  = НовоеВзаимодействие.Запустить(Истина);

Если Результат = -1 Тогда

Текст = НовоеВзаимодействие.ДополнительныеДанные.Получить("query").Значение;

КонецЕсли;

Возврат Текст;
#КонецЕсли

КонецФункции

в нашем случае через RS:CORE без взаимодействия с интернетом работать не будет.

Дмитрий. А нет ли какого то описания этого api, это к тому может можно как то управлять видимостью диалогового окна активации распознавания (как, например, в случае с rs:Core оно не видно и это здорово, ибо оно огромно и закрывает полэкрана), длительностью в течении которого он слушает?

Данный вызов не поддерживает такие параметры. Так же, Google Speech Recognition API не имеет механизмов ограничения длительности "прослушивания". Для реализаций всех ваших требований (оффлайн распознавание, регулировка длительности и т.д.) лучше использовать отдельную библиотеку типа CMU Sphinx

Вы протестируйте сам принцип голосового управления.

если вас устроит сама концепция, то мы разработаем для вас голосовое распознование чтобы оно было без окон и off-line/

Ну то что вы прислали уже попробовано, все ок. Если б не было доп. окон и возможность управления длительностью прослушивания, то вообще супер.

Просто сами команды короткие, а время прослушивания большое, а если наговаривать пакеты команд, то не хватает времени прослушивания, собственно это основная засада

тут тогда может речь идти про платную доработку.
нужно с вашей стороны кратко список настроек и функций которые вы хотите видеть от распознавание голоса. 

Сервис поддержки клиентов работает на платформе UserEcho