0
Исправлен

DT40 проблемы со сканером в мобильном клиенте 1С

Orlikov, Vyacheslav 8 месяцев назад в UROVO обновлен Михаил Феоктистов 8 месяцев назад 9

Добрый день! У нас перестали функционировать ШК и QR через сканер ТСД DT40 PKQ1.190922.001 в мобильном клиенте 1С, вибрация о считывании есть, но информация не проходит в мобильном клиенте 1С. Если считывать ШК через камеру в том же мобильном клиенте, то информация и операции проходят. Мобильный клиент 8.3.16.142; 1С:Предприятие 8.3 (8.3.18.1208); конфигурация 2.4.14.164. Что можно проверить и как исправить?

ХОРОШО, МНЕ ПОНРАВИЛОСЬ
Оценка удовлетворенности от Orlikov, Vyacheslav 8 месяцев назад
На рассмотрении

Добрый день.

Какой драйвер сканера используете?

Также в настройках сканера на ТСД должна быть снята галочка "Сканировать в поле ввода".

галочка "Сканировать в поле ввода" снята, драйвер выбирали RightScan (устройство ввода) в мобильном клиенте

Попробуйте использовать наш драйвер IDD. Для этого нужно внести изменения в вашу конфигурацию:

1) В модуле приложения объявить экспортную переменную

Перем глВК_IDD Экспорт;
2) В Процедура ПриНачалеРаботыСистемы() вставьте
#Если МобильноеПриложениеКлиент ИЛИ МобильныйКлиент Тогда
//RightScan++

Если ПодключитьВнешнююКомпоненту("ОбщийМакет.IDD", "IDD", ТипВнешнейКомпоненты.Native) Тогда

Попытка
глВК_IDD = Новый ("AddIn.IDD.IDD");
глВК_IDD.Подключить("Barcode");
//глВК_IDD.Подключить("Keyboard");
Исключение
Сообщить("Не удалось загрузить IDD");

КонецПопытки;

Иначе
Сообщить("Не удалось подключить IDD");

КонецЕсли;

//RightScan--

#КонецЕсли
3) В Процедура ОбработкаВнешнегоСобытия добавить следующие строчки
#Если МобильноеПриложениеКлиент ИЛИ МобильныйКлиент Тогда


//РаботаСВнешнимОборудованием
// Подготовить данные


//RightScan+++
Если Источник = "IDD" И Событие = "Barcode" тогда
Массив = Новый Массив;
массив.Добавить(Данные);
Массив.Добавить(Неопределено);
Оповестить("ScanData", массив, "ПодключаемоеОборудование");
КонецЕсли;
//RightScan---
#Иначе
ОписаниеСобытия = Новый Структура();
ОписаниеОшибки = "";

ОписаниеСобытия.Вставить("Источник", Источник);
ОписаниеСобытия.Вставить("Событие", Событие);
ОписаниеСобытия.Вставить("Данные", Данные);

// Передать на обработку данные
Результат = МенеджерОборудованияКлиент.ОбработатьСобытиеОтУстройства(ОписаниеСобытия, ОписаниеОшибки);
Если Не Результат Тогда
ОбщегоНазначенияКлиентСервер.СообщитьПользователю(НСтр("ru='При обработке внешнего события от устройства произошла ошибка.'")
+ Символы.ПС + ОписаниеОшибки);
КонецЕсли;

#КонецЕсли
//Конец РаботаСВнешнимОборудованием
4) В макетах добавить макет с названием IDD тип внешняя компонента и загрузить туда это файл IDD (1).zip

не получается скачать IDD (1).zip нет досутпа

помогло, сканер заработал. благодарю!

Сервис поддержки клиентов работает на платформе UserEcho