0
На рассмотрении

Ошибка при выгрузке весового товара из ТСД UROVO i6200 в Управление торговлей 10.3

Ольга 777 4 месяца назад в UROVO обновлен Александр К (Специалист направления поддержки 1С) 4 месяца назад 20

Добрый день!  ТСД UROVO i6200 и Управление торговлей 10.3. Данные в ТСД загружается по весовому и по штучному товару нормально. При считывании весовой этикетки - товар находится правильно и правильно встает вес.

Но когда начинаем выгружает данные в документ 1с - данные по штучному товару выгружаются нормально, а весовой товар выгружается - но количество не встает.

На рассмотрении

Добрый день, опишите подробнее, что в документе 1С на ТСД и что выгружается на ПК

На ТСД товар который посчитали  (например: Фарш свиной ,кг, цена 242, факт 0,084)

в 1с выгружается - Наименование (фарш свиной) и ед. измерения (кг) , а колонка количество пустая.

Вообще от того, весовой или штучный штрихкод выгрузка не зависит, ТСД выгружает 2 поля - штрихкод (такой как на экране ТСД) и количество, далее этот ШК обрабатывается на ПК. Можете прислать фото экрана ТСД и экран ПК с загруженным документом.

Также сохраните "Документ 1С" на ТСД в файл и пришлите этот файл.

А как заведен этот товар в УТ 10.3 - как весовой или нет? И какой у него штрихкод?

Конечно, стоит в карточке товара галочка весовой товар и задан код весового товара.

Попробуйте снять галочку весового штрихкода, в качестве штрихкода заполнить первые 7 знаков весового штрихкода (например "2300045"), выгрузить базу товаров на ТСД, установить в настройках сканирования в мобильной торговле префикс весового штрихкода ("23"), отсканировать ШК весового товара в документ 1С на тсд, загрузить данные в документ на ПК

мы не можем этого сделать , выгружаем из программы весы с печатью этикеток. Они тогда не будут грузиться если не будет этой галочки и кода весового товара

Смысл в таком терминале, если количество не встаёт. Обработку можно переписать , чтобы работало правильно?

Дело не в обработке и не в мобильной торговле, а в конфигурации УТ 10.3, обработка штрихкодов происходит в конфигурации, если только в ней изменения вносить

Смотрите - если этот же штрих-код считать сканером в этот же документ - то встанет и товар и количество- может все таки можно что то сделать?

значит, если не выгружать базу товаров, установить автопривязку ШК в настройках мобильной торговли, отсканировать не устанавливая префикс и загрузить на ПК - загрузится корректно

у нас сетевой клиент - очень много торговых точек - торгуют мясными продуктами - основной товар весовой

пожалуйста посмотрите смотрите в штрихкоде зашифровано 23 - префикс весового товара, потом 5 цифр это код товара - для идентификации в 1с, следующие 5 цифр это вес.

Добрый день! У вас получилось что-нибудь сделать?

Добрый день.

Нужно изменить конфигурацию УТ

В модуле объекта Обработки ТОСервер в Процедуре ОбработатьТаблицуШтрихкодов нужно вставить 3 строчки (выделено жирным шрифтом):

Если Не РезультатЗапроса.Пустой() Тогда
РезультатЗапроса = РезультатЗапроса.Выбрать();
РезультатЗапроса.Следующий();

Номенклатура = РезультатЗапроса.Номенклатура;
ХарактеристикаНоменклатуры = РезультатЗапроса.ХарактеристикаНоменклатуры;
СерияНоменклатуры = РезультатЗапроса.СерияНоменклатуры;
Качество = РезультатЗапроса.Качество;
ЕдиницаИзмерения = РезультатЗапроса.ЕдиницаИзмерения;
Количество = Количество * РезультатЗапроса.Количество;

//RS
Если Не ЗначениеЗаполнено(Количество) Тогда
Количество = СтрокаТЧ.Количество;
КонецЕсли;
//~RS

НоменклатураНайдена = Истина;
КонецЕсли;
КонецЕсли;

Сервис поддержки клиентов работает на платформе UserEcho