0
Исправлен

Urovo i6200

Максим Еремин 11 месяцев назад в UROVO обновлен Юлия Лукоянова (Руководитель службы поддержки по оборудованию) 10 месяцев назад 29

В режиме мобильного клиента, когда подключаемся к базе 1С, не удается установить драйвер ТСД. т.е. не работает сканирующий модуль, хотя делаем по инструкции.

ХОРОШО, МНЕ ПОНРАВИЛОСЬ
Оценка удовлетворенности от Максим Еремин 10 месяцев назад
На рассмотрении

Добрый день! Сообщите, пожалуйста:

-точную модель терминала

-серийный номер терминала

-версию Android

-номер сборки

-версию RSCore и RSCore UI

Urovo MC6200S-SH3S5E000H

68281837756145

Android 5.1

-номер сборки - где можно посмотреть?

-версию RSCore и RSCore UI - где можно посмотреть?

Добрый день!

Номер сборки: Настройки  - о телефоне

RSCore и RSCore UI: Настройки - приложения - все

Номер сборки: SQ42T_P1_00AX_YBYDE_AU1616_418_R_EN_180912_01

RSCore 3.00

есть RS: Core Интерфейс

версия 1.26

В приложении сканер все прекрасно сканируется. Я пытаюсь настроить работу ТСД в качестве мобильного клиента 1с для конфигурации с поддержкой библиотеки подключаемого оборудования.В 1с на ПК добавляю новый драйвер из файла (внешняя компонента RS-Driver-1.21.zip https://yadi.sk/d/FQNqq2t8bgfPKA), затем публикую конфигурацию на web-сервере, подключаюсь мобильным клиентом с ТСД.Подключаемое оборудование - Создать. Тип оборудования: Сканеры штрих-кода. Драйвер оборудования Rightscan: Устройства ввода. Записать. Настроить. Установить драйвер. После этого ошибка (Во вложении).

+1

Для работы в мобильном клиенте в конфигурации нужно добавить общий макет, тип внешняя компонента, в него загрузить драйвер.

Процедура инициализации драйвера:

Процедура ИнициализироватьВнешнююКомпонентуRSDriver () Экспорт

#Если МобильноеПриложениеКлиент ИЛИ МобильныйКлиент Тогда

Если ПодключитьВнешнююКомпоненту("ОбщийМакет.ДрайверRSDriverУстройстваВвода", "RSDriver", ТипВнешнейКомпоненты.Native) Тогда

Попытка
глВКRSDriver = Новый ("AddIn.RSDriver.RSDriver");
глВКRSDriver.Подключить("Barcode");
Исключение
Конецпопытки;

КонецЕсли;

#КонецЕсли

КонецПроцедуры

В БПО ничего подключать не нужно, только опубликовать конфигурацию.

Спасибо. По этой инструкции удалось запустить.
Остался вопрос с мобильным приложением RS Driver API (Core). При публикации конфигурации на web-сервере и подключении к ней мобильным приложением с ТСД получал ошибку на ТСД: 

Компонента RSExchange не лицензирована на этом устройстве.
Поэтому работу в этом режиме так же не удалось настроить.

Остался вопрос с мобильным приложением RS Driver API (Core). При публикации конфигурации на web-сервере и подключении к ней мобильным приложением с ТСД получал ошибку на ТСД:

Компонента RSExchange не лицензирована на этом устройстве.

Подскажите?

Так же изучая вопрос возможности доработки конфигурации RS Driver API (Core) при публикации конфигурации на web-сервере и подключеннии к ней мобильным приложением с ТСД получал ошибку на ТСД: Компонента RSExchange не лицензирована на этом устройстве. Поэтому работу в этом режиме так же не удалось настроить.

Здравствуйте, при сканировании dataMatrix во вложении сканер ТСД подвисает более чем на 15-20 сек. С чем может быть связано? Как настроить.

Добрый день! Попробуйте снять настройки сканирования неиспользуемых ШК. Scanner - настройки - настройки по типам кодов

Остался вопрос с мобильным приложением RS Driver API (Core). При публикации конфигурации на web-сервере и подключении к ней мобильным приложением с ТСД получал ошибку на ТСД:

Компонента RSExchange не лицензирована на этом устройстве.

Подскажите?

Этим вопросом сейчас занимаемся, свяжемся в ближайшее время.

Еще вопрос возник про доработку приложения 1С: Мобильная торговля в части поддержки маркировки лекарств.

Расскажите подробнее про состав ПО на ТСД, функционал и можно ли протестировать? У нас собственная конфигурация на основе УТ 11 и Розницы 2 с внедренной библиотекой МДЛП.

Добрый день! Мобильная торговля работает в режиме обмена через БПО.

Сканирует, собирает ШК и отправляет их в 1С. Так же можно загрузить в память терминал НСИ из 1С, а далее инициировать, к
примеру, поступление или отгрузку, либо другой документ. При
сканировании товара в него будет заполняться количество. Сделать все это
можно с помощью приложения "Мобильная торговля". Это приложение идет
вместе с терминалом бесплатно (предустановлено). https://www.rightscan.ru/solutions/rs-mobile-acs/ К приложению есть множество инструкций и видеоинструкций. По вопросу тестирования

оборудования вы можете обратиться к нашим менеджерам.

Добрый день! Зайдите: Мобильная торговля - Меню (в верхнем левом углу) - Проверка обновлений - Загрузить. Загрузите последнюю версию Мобильной торговли (3.57). Далее выполните действия по видеоинструкции

Сервис поддержки клиентов работает на платформе UserEcho