0
Исправлен

Urovo i6300S + Мобильная торговля = не умещается вес в строках документов

Владислав Васильев 5 месяцев назад в UROVO • обновлен Иван (Специалист службы поддержки по оборудованию) 5 месяцев назад 7

Вы дорабатывали для нас мобильную версию 1С для терминалов сбора данных Urovo по договору № 112945К041017 от 04.10.17. Версия приложения 0.3.39 на платформе 8.3.9.86.


Недавно выяснилось, что в портретной ориентации терминалов Urovo i6300 в табличной части документов в поле фактического количества числа вида 123,456 (кг) не умещаются и обрезаются справа до одного или двух знаков после запятой с заменой не уместившихся цифр троеточием. Для того, чтобы увидеть верный вес, приходится разрешать в настройках автоповорот экрана и крутить-вертеть сам терминал, что крайне неудобно. Ещё бОльшие веса (вида 1234,567) нам пока не встречались, но вполне могут встретиться. Как бы исправить эту недоработку?


Как ни странно, проблема проявляется в Urovo i6300 с бОльшим разрешением экрана и не проявляется в i6200 с меньшим разрешением. Изменение размера шрифтов в настройках системы не влияет на размер шрифта в "1С Мобильная торговля". И, кстати, приводит к аварийному закрытию 1С без сохранения данных.

Попробуйте установить версию 3.45. и проверить работу. Для старого ACS V1.0 функционала исправили.
https://yadi.sk/d/PhV2p5m73YAHGR

Большое спасибо, теперь работает как надо.

Особенности:

1) Обновлять старую версию приложения нельзя - невозможно запустить новую из-за бесконечно повторяющейся ошибки. Удаление всех данных в старой версии (из самого приложения) не помогает, нужно полностью удалять старую версию перед установкой новой.

2) После загрузки номенклатуры сканирование товара в документы не работает, пока не перезагрузишь ТСД.

Доработанная мной обработка для 1С 7.7 Торговля Выгрузить штрихкоды в ТСД UROVO.ert - может кому пригодится. А то ваша совсем уж наспех была сделана и выгружала втрое больше записей, чем нужно.

Обработка вызывает процедуру глобального модуля, цитирую её текст. Форматирование текста здесь как исходного кода, работает только в момент написания сообщения и теряется после его публикации.


Процедура глДобавитьСтроку(КЧему,Что,Счетчик=0,ОграничиватьКоличествоСтрок=0) Экспорт

//Чтобы размер окна не вышел за размеры экрана, когда текст предупреждения слишком большой, можно четвёртым параметром,

//не равным нулю, заставить процедуру вернуть текст с количеством строк, ограниченным некоторым значением.

//От получившегося после прибавления к КЧему очередной порции текста Что оставляем в этом случае первые 18 строк и последнюю,

//между ними будет расположена строка с многоточием, означающая вырезанные строки.

Перем х,ВспомСтр,ВсегоСтрок;

КЧему=КЧему+?(ПустаяСтрока(КЧему)=1,"",РазделительСтрок)+Что;

Если ОграничиватьКоличествоСтрок<>0 Тогда

ВсегоСтрок=СтрКоличествоСтрок(КЧему);

Если ВсегоСтрок>20 Тогда

ВспомСтр=КЧему;

КЧему="";

Для х=1 По 18 Цикл

КЧему=КЧему+?(х=1,"",РазделительСтрок)+СтрПолучитьСтроку(ВспомСтр,х);

КонецЦикла;

КЧему=КЧему+РазделительСтрок+"....."+РазделительСтрок+СтрПолучитьСтроку(ВспомСтр,ВсегоСтрок);

КонецЕсли;

КонецЕсли;

Счетчик=Счетчик+1;

КонецПроцедуры

Сервис поддержки клиентов работает на платформе UserEcho