Форум для оказания технической поддержки партнерам и клиентам компании RightScan.


+1
Отвечен

ТСД Urovo и Штрих-М

Добрый день, подскажите как подключить Urovo i6200 к Штрих-м торговое предприятие 5 ?

Что вводить?

Скачал внешнюю компоненту для подключения мобильного устройства к 1С через подключаемое оборудование, библиотека RS Exchange не регистрируется, COM объект тоже.

Тест связи проходит, в ТП5 при ТСД драйвера rightscan вылезает ошибка -

Не удалось создать объект "" для драйвера "Драйвер терминалов сбора данных ("RightScan")". {ОбщийМодуль.РаботаСТорговымОборудованием.Модуль(10126)}: Ошибка при вызове конструктора (COMОбъект): -2147221005(0x800401F3): Недопустимая строка с указанием класса


Ответ

1. В справочнике драйверы торгового оборудования вводим:

2. В справочнике торговое оборудования прописываем драйвер:


+1
Отвечен

1С-Обработка для ТСД Urovo V5100

Добрый день!

Приобретен ТСД Urovo V5100.

Платформа 1С:Предприятие 8.3 (8.3.10.2667)


1. Нужна 1С-обработка и драйвер для подключения торгового оборудования к программе 1С:Управление торговлей, редакция 10.3 (релиз последний).


2.  Нужна 1С-обработка и драйвер для подключения торгового оборудования к программе 1С:Управление производственным предприятием» ред. 1.3(релиз последний).



Ответ

Добрый день.

Попробуйте обработку.

Спасибо.

+1
Исправлен

Не сканируется штрих код

На первой картинке на терминалах urovo 6200 штрих код не сканирует. На новом с прошивкой rs core сканирует. В чем может быть дело.

На второй картинке никто не может прочитать штрих код.




Ответ

на самом деле возможно прошивка и не какая не понадобиться.
С

делайте настройки сканера как указанно на рисунке. у меня вес получилось и ваши ШК читаются.

0

ТСД UROVO документ 1с присвоить номер или контрагента

san059 6 часов назад в UROVO 0

Запускаем маркировку на УТ 10.3 и ТСД UROVO DT30. Склад и менеджеры разделены территориально. Так как из 1С нельзя передать данные о том, что необходимо собрать на склад (в ТСД), то менеджер на принтер склада отправляет документ для сборки. Кладовщик собирает товар и считывает коды маркировок на ТСД создав новый документ. Бывает менеджер и кладовщик не состыковались и на ТСД создается несколько документов 1С, может ли кладовщик присвоить номер документу на ТСД или ввести контрагента (не нашел такой функции), чтобы в списке документов, когда менеджер ему позвонит он без проблем смог открыть документ увидев введённый номер или контрагента?

0
На рассмотрении

UROVO i6200A. Мобильный клиент.

Алексей В. 11 часов назад в UROVO обновлен 7 часов назад 5

Есть UROVO i6200A, пытаюсь на нем запустить сканер из мобильного КЛИЕНТА 8.3.17.67, НЕ мобильного приложения.
Работают ли драйвера из 1С БПО для мобильного приложения или ваш драйвер RSDriver 1.20 именно в мобильном клиенте?(1.21 пока не пробовал, сегодня собираюсь)

Эти два драйвера устанавливаются и подключаются без ошибок , но на кнопку SCAN никакой реакции.
Как устанавливаю драйвера и подключаю устройство:

Функция ИнициализироватьДрайверБПО() Экспорт
//#Если МобильныйКлиент Тогда
Оповещение = Новый ОписаниеОповещения("ПодключитьВК_Из_БПО", ЭтотОбъект);
НачатьУстановкуВнешнейКомпоненты(Оповещение, "ОбщийМакет.ДрайверRightScanУстройстваВвода");
//#КонецЕсли
Возврат Ложь;
КонецФункции
Процедура ПодключитьВК_Из_БПО(Дополнительные_Сообщения)Экспорт 
Оповещение = Новый ОписаниеОповещения("НастройкаВК_Из_БПО", ЭтотОбъект);
НачатьПодключениеВнешнейКомпоненты(Оповещение, "ОбщийМакет.ДрайверRightScanУстройстваВвода","RSDriver", ТипВнешнейКомпоненты.Native);
КонецПроцедуры
Процедура НастройкаВК_Из_БПО(Подключено, Дополнительные_Сообщения)Экспорт 
Если Подключено Тогда
Попытка
глВКRSDriver = Новый ("AddIn.RSDriver.RSDriver");//Создает объект драйвера
ПодключитьУстройство();
Исключение
_Сообщение = ОписаниеОшибки();
Сообщить(_Сообщение);
МобильныйМодульСервер.Записать_СообщениеВРегистрЛог(_Сообщение);
_Сообщение = "Ошибка создания класса БПО";
Сообщить(_Сообщение);
МобильныйМодульСервер.Записать_СообщениеВРегистрЛог(_Сообщение);
Подключено = Ложь;
Конецпопытки;
Иначе
_Сообщение = "Компонента БПО не загружена";
Сообщить(_Сообщение);
МобильныйМодульСервер.Записать_СообщениеВРегистрЛог(_Сообщение);
КонецЕсли;
КонецПроцедуры

Подключает само устройство

Процедура ПодключитьУстройство()
Попытка
глВКRSDriver.УстановитьПараметр("Barcode_BEEP",Истина);
глВКRSDriver.УстановитьПараметр("Barcode_BZZ",Истина);
Ответ = глВКRSDriver.Подключить("Barcode");             Если Ответ Тогда
_Сообщение = НСтр("ru='Устройство подключено ! ! !'") + Символы.ПС + ОписаниеОшибки();
Сообщить(_Сообщение);
МобильныйМодульСервер.Записать_СообщениеВРегистрЛог(_Сообщение);
Иначе
_Сообщение = НСтр("ru='Ошибка подключения!'") + Символы.ПС + ОписаниеОшибки();
Сообщить(_Сообщение);
МобильныйМодульСервер.Записать_СообщениеВРегистрЛог(_Сообщение);
КонецЕсли;
Исключение
_Сообщение = НСтр("ru='Ошибка вызова метода <ОбъектДрайвера.Подключить>.'") + Символы.ПС + ОписаниеОшибки();
Сообщить(_Сообщение);
МобильныйМодульСервер.Записать_СообщениеВРегистрЛог(_Сообщение);
КонецПопытки;
КонецПроцедуры

Ответ = глВКRSDriver.Подключить("Barcode"); - ошибки не выдает, но и сканер не реагирует.
Правильно ли я подключаю через ("Barcode", может надо "Keyboard" или надо еще какие то параметры установить ?
На этом ТСД еще установлена 1С Мобильная торговля, там сканер естественно работает.

0
На рассмотрении

Интеграция ТСД с 1с через интернет

sher_70 1 день назад в UROVO обновлен Вадим (Специалист службы поддержки по оборудованию) 14 часов назад 1

Прошу уточнить, имеется ли возможность подключить ТСД UROVO DT50 к облачной или коробочной 1С  УНФ при помощи интернета, а не WI-FI или USB? Дело в том что у нас склад находится удаленно от бухгалтерии,  имеет только мобильный интернет, из оборудования только терминал сбора данных, который имеет возможность подключения к интернету.  

0
На рассмотрении

Ошибка при попытке сохранить документ 1с в файл

Александр М. 3 дня назад в UROVO обновлен 6 часов назад 9

0
На рассмотрении

маркировка. контроль поступлений. УТ 10.3

san059 4 дня назад в UROVO обновлен Михаил Феоктистов 4 дня назад 3

Добрый день. Поставщик по ЭДО присылает Поступления, в котором заполнены КМ. Задача сверить КМ в поступлении и фактически полученные. Можете пояснить как это проще сделать при интеграции DT 30 с УТ 10.3. На сколько я понимаю нужно из 1С как то передать ТЧ поступления в ТСД в документ контроль поступления (но как это сделать я не смог разобраться)? Или какой то другой механизм использовать?

0
Отвечен

запись в произвольную БД

Здравствуйте,

есть ли возможность организовать работу ТСД в режиме Wi-Fi сканера с одновременной записью в произвольную базу SQL без необходимости написания приложения для ТСД? Либо если первый вариант невозможен, может ли ТСД по TCP или по UDP открывать соединение по нужному адресу и кидать туда отсканированные коды?

0
Отвечен

Google Play Market для ТСД DT30

Добрый день.

В прошивке ТСД Urovo DT30 нет сервисов Google. Как можно установить Play Market или получить прошивку с сервисами?



Сервис поддержки клиентов работает на платформе UserEcho